Rackpsace Webmail login issues
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 03:52 UTC
Identified
We are currently experiencing a technical issue that is preventing users from logging in to Rackspace's email service for newly added aliases or mailboxes.

Our team is coordinating with the Rackspace team on this matter. We sincerely apologize for the inconvenience caused.
Posted Dec 02, 2024 - 09:14 UTC
This incident affected: Add-on Services (Rackspace Email).