Accessibility issues with Rackspace webmail portal
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 12:37 UTC
Investigating
We are receiving a number of complaints related to customers not able to login to their Rackspace mailbox via webmail portal or using any third party email clients. The issue has been identified by the Rackspace team and they are working on fixing the issue. We will update our status page as soon as we hear update from Rackspace team. Any inconvenience caused because of this issue is highly regretted.
Posted Feb 18, 2023 - 18:28 UTC
This incident affected: Add-on Services (Rackspace Email).