Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted May 06, 2026 - 10:11 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 06, 2026 - 09:00 UTC
Scheduled
We will be performing a rolling update of the Apache HTTP Server across our fleet of Debian 12 servers. This update upgrades Apache from version 2.4.66 to 2.4.67.
Activity Time: Activity start time: 6th May, 09:00 UTC Activity end time: 6th May, 19:00 UTC
Impact Area:
Security: Cloudways users are not impacted by the recently detected vulnerability (CVE-2026-23918) in Apache v2.4.66 due to our platform’s security configurations. However, we are proactively updating to the latest stable version (2.4.67) to ensure continued server hardening. Service Restart: Please note that Apache will restart once during this update to apply the changes. Your site may experience a brief interruption during this period. Duration: This update is being rolled out in phases and may take up to 10 hours to complete across the entire fleet.
We will promptly inform you as soon as this maintenance is complete. Thank you for your patience and understanding as we work to improve your experience. If you have any questions, please feel free to reach out to our support team.