Cloudways Platform UI issues

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 14:52 UTC

Monitoring

We have identified the root cause affecting the Platform Console UI and have deployed a fix. Users should now be able to log in and navigate the dashboard normally without experiencing unexpected logouts.

We are closely monitoring the platform's stability to ensure performance remains optimal. Thank you for your patience while we resolved this.
Posted Jul 01, 2026 - 10:26 UTC

Investigating

We are currently investigating an issue with the Cloudways Platform Console. Some users may experience intermittent performance issues, loading errors, or frequent, unexpected logouts while navigating the dashboard.

Our engineering team is actively diagnosing the root cause to restore full stability as quickly as possible. Please note that this does not affect your hosted applications or live websites, which remain fully online and operational.

We sincerely apologize for the disruption and will provide another update as soon as more information becomes available.
Posted Jul 01, 2026 - 09:38 UTC
This incident affected: Cloudways Cloud Platform Console.