Degraded Performance | Racksapace Addon
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Nov 01, 2021 - 18:56 UTC
Investigating
We have observed issues related to our Rackspace email addon service due to which customers are not able to create, remove, or modify mailboxes. The issue has been already identified by the Rackspace team and they are working on fixing the issue as soon as possible. Any inconvenience caused in this regard is highly regretted.
Posted Nov 01, 2021 - 15:14 UTC