VULTR Outage Affecting Frankfurt Region

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 15:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 15:38 UTC

Identified

Our upstream provider VULTR has reported that an outage or maintenance window is affecting a subset of users in the Frankfurt region. We will continue to monitor the situation and share further updates as they become available.
Posted Jul 13, 2026 - 12:26 UTC
This incident affected: Cloud Providers (Vultr).