Rackspace Web portal login issues
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 10:22 UTC
Identified
We are currently experiencing a technical issue that is affecting Rackspace's Hosted Email Webmail login. Users may experience an error when attempting to log in to the Webmail website.

Our backend team is investigating the issue and coordinating with the Rackspace team. We will post an update on the issue as soon as possible. We sincerely regret any inconvenience caused to our customers.
Posted Jun 05, 2023 - 10:17 UTC
This incident affected: Add-on Services (Rackspace Email).