Let's Encrypt API Outage

Incident Report for Cloudways

Resolved

The issue with Let's Encrypt API service outage has been resolved. Let's Encrypt has deployed mitigations for their internal DNS server failures, and certificate issuance is now succeeding.
Posted Jul 22, 2025 - 08:06 UTC

Investigating

We have Identified that Let's Encrypt experiencing API service outage. Their team is currently investigating the issue. We will provide updates as soon as more information becomes available. We sincerely apologize for any inconvenience this may cause
Posted Jul 21, 2025 - 19:36 UTC