UK Region Phone Number Verification Issue
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 20:01 UTC
Investigating
We are aware of a technical issue preventing our UK customers from verifying their phone numbers. Our team is actively working on a resolution, and we expect to have this fixed shortly. We apologize for any inconvenience caused.
Posted Apr 17, 2024 - 18:21 UTC
This incident affected: Cloudways Cloud Platform Console.