Rackspace Webmail Access Issue!

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 10:21 UTC

Investigating

Rackspace is currently experiencing an issue affecting access to Webmail. We would like to confirm that our engineers are continuously in contact with the Rackspace team and reviewing this. We will update you as soon as we secure any successful response and full service is restored.
Posted Oct 29, 2025 - 03:58 UTC
This incident affected: Add-on Services (Rackspace Email).