Service degradation due to Cloudflare global outage

Incident Report for Cloudways

Resolved

We have received confirmation from Cloudflare that their services have returned to normal and no further errors or latency are being observed across their network. As a result, the issue affecting access to the Cloudways platform has been resolved.
We sincerely appreciate your patience and understanding during this disruption.
Posted Nov 18, 2025 - 17:57 UTC

Monitoring

The Cloudflare team has implemented a fix. We continue to monitor for errors to ensure all services return to normal.
Posted Nov 18, 2025 - 15:11 UTC

Update

We are continuing to monitor the Cloudflare status.
Posted Nov 18, 2025 - 12:57 UTC

Investigating

Cloudflare is currently facing a global service outage that’s affecting websites and services using their network. This includes the Cloudways website, platform and related services. We’re actively monitoring Cloudflare’s updates and will keep our customers informed as the situation evolves.
Posted Nov 18, 2025 - 12:03 UTC
This incident affected: Cloudways Home and Cloudways Cloud Platform Console.