New Addon Subscribers are Unable to Create Mailbox in Rackspace

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 02:40 UTC

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 13:44 UTC

Investigating

We are currently facing a technical issue that is preventing new Rackspace Addon users from creating mailboxes in Rackspace's email service.
Our team is working on resolving this matter. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Nov 24, 2025 - 13:44 UTC
This incident affected: Add-on Services (Rackspace Email).