Digital Ocean Droplet Issue - New York Region

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 10:27 UTC

Investigating

We are observing an issue with some of the Droplets in the New York region on Digital Ocean. During this time, users may see their server being inaccessible. Our Engineering team is working closely with DO team to resolve this issue. We apologize for the inconvenience and will share an update once we have more information.
Posted May 30, 2025 - 14:07 UTC
This incident affected: Cloud Providers (DigitalOcean).