Linode Jakarta Partial Outage

Incident Report for Cloudways

Monitoring

Linode has confirmed that the connectivity issues in their Jakarta region have been addressed. Their team will continue to monitor the situation to ensure stability.
Posted Mar 20, 2026 - 18:18 UTC

Identified

Our upstream provider, Linode, is currently experiencing a partial outage in their Jakarta region. Their engineering team is actively working to resolve the issue as soon as possible. We regret any inconvenience this may cause.
Posted Mar 20, 2026 - 11:42 UTC
This incident affects: Cloud Providers (Linode).