Rackpsace Webmail issue
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jul 20, 2024 - 19:09 UTC
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 10:04 UTC
Investigating
We are currently experiencing a technical issue that is preventing users from logging in to Rackspace's email service and unable to add new mailboxes.

Our backend team is coordinating with the Rackspace team on this matter. We will post an update on the issue as soon as possible. We sincerely apologize for any inconvenience this may have caused our customers.
Posted Jul 19, 2024 - 10:03 UTC
This incident affected: Add-on Services (Rackspace Email).