Rackspace Addon Features
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 03:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2024 - 02:13 UTC
Identified
We acknowledge the issue with the Rackspace addon operations and want to assure you that we are currently investigating this with the Rackspace team.

This will not cause any issue with the existing email boxes created through the Rackspace Addon.
Posted Apr 01, 2024 - 22:42 UTC
This incident affected: Add-on Services (Rackspace Email).