Rackspace webmail login issue for new user

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 15:25 UTC

Identified

We are currently facing a technical issue preventing new users from logging into Rackspace Webmail. However, please note that email delivery for existing users remains unaffected.

Our team is actively working with Rackspace to resolve this matter as soon as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Feb 11, 2025 - 10:53 UTC
This incident affected: Add-on Services (Rackspace Email).