Rackspace Webmail Login Issue

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Nov 25, 2024 - 05:49 UTC

Identified

Rackspace is currently facing issues with webmail login, and their engineers are actively investigating the issue.
More details will be posted as it becomes available.
Posted Nov 24, 2024 - 21:02 UTC
This incident affected: Add-on Services (Rackspace Email).