Digital Ocean Droplet Creation Issue

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted May 23, 2025 - 03:53 UTC

Investigating

We are currently experiencing issues with Droplet creation across multiple DigitalOcean regions. As a result, attempts to add new servers via the Platform may fail.
Please note that existing servers are not affected by this issue.
Our engineering team is actively working with the relevant teams to resolve the problem. We apologize for any inconvenience this may cause and will share updates as soon as more information becomes available.
Posted May 22, 2025 - 15:17 UTC
This incident affected: Cloud Providers (DigitalOcean) and Cloudways Cloud Platform Service.