Issues with Elastic Email Addon
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jun 29, 2021 - 08:29 UTC
Identified
We are observing an intermittent issue with Elastic Email, due to which their email delivery is temporarily affected. We are in coordination with Elastic Email and they are actively pursuing to resolve the issue asap.

Any inconvenience that might be caused is deeply regretted.

We will update the status page as soon as we have any additional information.
Posted Jun 29, 2021 - 06:18 UTC