Slowness issues on Cloudways Platform
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Aug 01, 2024 - 06:46 UTC
Investigating
We are currently experiencing some slowness on our platform. Our team is actively working to identify and resolve the issue as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience and understanding. We will provide updates as soon as we have more information.
Posted Jul 31, 2024 - 05:56 UTC
This incident affected: Cloudways Home, Cloudways Cloud Platform Console, Cloudways Cloud Platform Service, Cloudways Support, Cloudways API, Cloud Providers (AWS, DigitalOcean, Google Cloud, Linode, Vultr), and Add-on Services (Cloudflare Enterprise, DNS Made Easy, Elastic Email, Rackspace Email, Stackpath).