AWS Middle East (Bahrain) Outage

Incident Report for Cloudways

Update

AWS is currently experiencing a power outage affecting two of its three data centers in Bahrain. The remaining center is currently over capacity, leading to widespread service failures. Since backups are hosted in the same region, recovery is dependent on AWS restoring local power and connectivity. We are monitoring the situation 24/7 and will update you the moment services begin to recover.
Posted Mar 02, 2026 - 18:28 UTC

Identified

Our upstream provider, Amazon Web Services (AWS), is currently experiencing a connectivity and power outage in the Bahrain region, impacting instances hosted in the ME-SOUTH-1 region.

Their technical teams are actively investigating the issue and working to restore services as quickly as possible. We regret the inconvenience this may cause.
Posted Mar 02, 2026 - 08:05 UTC
This incident affects: Cloud Providers (AWS).