Digital Ocean London DNS
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted May 19, 2021 - 06:51 UTC
Identified
We have identified an issue on the Digital Ocean London region related to DNS and currently have our dedicated resources working on it. In the meantime, Users may face some issues while performing operations on the server but it will have no impact on the currently running applications.
Posted May 19, 2021 - 05:29 UTC
This incident affected: Cloudways Cloud Platform Service.