Issues in Server Provisioning (with Vultr)

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 02:42 UTC

Investigating

Vultr has reported an incident affecting global server provisioning operations. They are continuing to investigate, and we are monitoring the situation closely. We will provide updates as soon as more information becomes available. We regret any inconvenience caused.
Posted Nov 23, 2025 - 20:42 UTC
This incident affected: Cloud Providers (Vultr).