Cloudways Autonomous: Partial Service Degradation in US (South Carolina)

Incident Report for Cloudways

Resolved

The issue has been resolved. Please contact our support if you continue to experience any related issues.
Posted Mar 17, 2026 - 09:20 UTC

Monitoring

Storage service is stable and fully restored. Our team continues to monitor system performance.
Posted Mar 16, 2026 - 22:37 UTC

Investigating

Some Cloudways Autonomous applications hosted in the US region may experience temporary connectivity issues due to a partial disruption in the underlying storage service. Our team is actively working with the infrastructure provider to restore full stability as quickly as possible.
Posted Mar 16, 2026 - 21:06 UTC