Partial outage in Vultr London

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Mar 16, 2023 - 18:35 UTC

Investigating

Our upstream provider, Vultr, is currently experiencing a partial outage in their London region. Their team is currently investigating the issue, and we regret any inconvenience this may cause.
Posted Mar 16, 2023 - 12:55 UTC
This incident affected: Cloud Providers (Vultr).