Intermittent issues on the Platform

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Aug 05, 2024 - 19:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2024 - 18:29 UTC

Investigating

We're currently experiencing a technical problem on our platform that's affecting operations such as SSL installation and renewal. Our Engineering team is addressing this issue as a top priority. We will keep our customers updated on our progress. We apologize for any inconvenience this may cause.
Posted Aug 05, 2024 - 17:23 UTC
This incident affected: Cloudways Cloud Platform Console.