UI Issue - Stuck Processes

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 08:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2026 - 06:58 UTC

Investigating

We’re aware of an issue causing some processes to become stuck in the UI. Our team is actively investigating and working to resolve it as quickly as possible. We regret any inconvenience caused and appreciate your patience.
Posted Apr 04, 2026 - 06:00 UTC