API Connectivity Issue with Digital Ocean
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 18:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2021 - 16:03 UTC
Investigating
We have observed that Digital Ocean is having issues with their API services globally which may cause problems while starting, stopping, attaching disk and provisioning servers.

Our Engineering team is in close coordination with Digital Ocean Engineers regarding this issue. We will update the status page as soon as we have any additional information. Any inconvenience that you might face is deeply regretted.
Posted Mar 17, 2021 - 14:48 UTC
This incident affected: Cloudways Cloud Platform Service.