Cloudways Homepage Issue
Incident Report for Cloudways
Resolved
Homepage is now operational
Posted Jul 28, 2021 - 01:29 UTC
Investigating
Cloudways home page is experiencing problems. Platform operations, console access, and customer servers are not affected. Our team is actively working on this. We will update as soon as it resolves. Any inconvenience caused is regretted.
Posted Jul 27, 2021 - 22:37 UTC
This incident affected: Cloudways Home.