Slow Platform Operations
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 21:57 UTC
Identified
We have identified an issue that has rendered our Cloudways Platform (https://platform.cloudways.com) to be slow in completing in-progress operations.

Our teams are actively working for the resolution, any inconvenience caused is highly regretted.

Regards,
Cloudways Team
Posted Mar 15, 2021 - 20:21 UTC