Rackspace Email Addon issue
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 03:05 UTC
Investigating
We are receiving a number of complaints from our customers concerning of creation of new mailboxes and login to their Rackspace mailbox via webmail portal. The issue has been identified by the Rackspace team and they are working on fixing the issue. Any inconvenience caused because of this issue is highly regretted.
Posted Jun 13, 2022 - 18:05 UTC