AWS | Degraded Performance at N. Virginia Region
Incident Report for Cloudways
Resolved
All issues happening in North Virginia region are fully resolved now. Any inconvenience caused to Cloudways customers during the incident period are deeply regretted.
Posted Dec 08, 2021 - 08:16 UTC
Update
We have identified that this is also affecting Let's Encrypt certificates issuance as it is taking longer than usual to validate new certificates. We continue to work closely with AWS and we will post more information as it becomes available
Posted Dec 07, 2021 - 20:55 UTC
Investigating
We are currently experiencing a Degraded Performance in AWS N. Virginia Region. We are in close coordination with AWS and would update once we get more information about this. Any inconvenience that might be caused is deeply regretted.
Posted Dec 07, 2021 - 19:03 UTC
This incident affected: Cloudways Cloud Platform Service.