Unable to Create Mailbox in Rackspace

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 09:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2025 - 08:06 UTC

Investigating

We are currently facing a technical issue that is preventing users from creating new mailboxes in Rackspace's email service.

Our team is coordinating with the Rackspace team on this matter. We sincerely apologize for the inconvenience caused.
Posted Jan 23, 2025 - 15:07 UTC
This incident affected: Add-on Services (Rackspace Email).