Rackspace Email Addon issue
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 16:57 UTC
Investigating
We are experiencing technical difficulties accessing the Rackspace control panel, which is hindering our ability to troubleshoot issues related to the Rackspace addon.

We are working with Rackspace team to resolve this issue and will update you as soon as possible. We apologize for any inconvenience caused.
Posted Jul 22, 2024 - 13:19 UTC
This incident affected: Add-on Services (Rackspace Email).