Let's Encrypt (LE) SSL installation failing
Incident Report for Cloudways
Resolved
The reported issue has been resolved by Let's Encrypt team.
Posted Jun 16, 2023 - 07:27 UTC
Monitoring
Let's Encrypt Team has identified the source of the problem, which was causing mismatching pre-certificates and certificates. Issuance has resumed.
Posted Jun 15, 2023 - 19:13 UTC
Investigating
We are currently experiencing failures in installing Let's Encrypt SSL certificates with an error message stating, "Let's Encrypt service is not available at the moment. Please try later."
The problem has been acknowledged by the Let's Encrypt community, and their team is actively working to resolve the issue. For more information and updates regarding this incident, please refer to the following link: https://letsencrypt.status.io/. If you have any inquiries, please don't hesitate to contact Cloudways Support. We apologize for any inconvenience caused.
Posted Jun 15, 2023 - 16:48 UTC
This incident affected: Cloudways Cloud Platform Service.