Email Issue - Elastic Email

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jul 18, 2023 - 13:47 UTC

Investigating

We are investigating an email delivery issue with Elastic Email.

During this time, users with the Elastic Email add-on may experience delay in email delivery.

We will share additional updates as we have more information.
Posted Jul 18, 2023 - 13:28 UTC
This incident affected: Add-on Services (Elastic Email).