Elastic Email Service Interruption
Incident Report for Cloudways
Resolved
This issue was resolved in early morning hours today UTC time, we apologise for the inconvenience caused to our valued customers.
Posted Jul 27, 2021 - 13:29 UTC
Identified
Issue has been identified, we are working with ElasticEmail to resolve it asap.
Posted Jul 26, 2021 - 17:51 UTC
Investigating
We are investigating the issue with Elastic Email service, inconvenience caused to our customers is deeply regretted, we are actively working to resolve this with Elastic Email.
Posted Jul 26, 2021 - 17:42 UTC