Issue with Rackspace Mailbox Operations
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 15:47 UTC
Investigating
We are aware of the issue where our customers are encountering difficulties in adding, deleting the Rackspace mailbox, and resetting mailbox logins. We are actively working with the Rackspace team to resolve this issue promptly. We apologize for any inconvenience caused.
Posted Apr 08, 2024 - 13:23 UTC
This incident affected: Add-on Services (Rackspace Email).