Rackpsace Webmail login issues
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 18:06 UTC
Investigating
We are currently experiencing a technical issue that is preventing users from logging in to Rackspace's email service.

Our backend team is coordinating with the Rackspace team on this matter. We will post an update on the issue as soon as possible. We sincerely apologize for any inconvenience this may have caused our customers.
Posted Oct 14, 2024 - 14:07 UTC
This incident affected: Add-on Services (Rackspace Email).