DigitalOcean Global Outage
Incident Report for Cloudways
Resolved
The issue has been resolved and confirmed on Digital Ocean status page as well https://status.digitalocean.com/
Inconvenience caused to our customers is regretted.
Posted Jun 14, 2022 - 11:08 UTC
Update
We are continuing to investigate this issue.
Posted Jun 14, 2022 - 07:09 UTC
Investigating
Approximately at 23:40 UTC DigitalOcean started experiencing a global outage which was mistakenly marked as resolved on our end. Our Engineering team is still in constant communication with DigitalOcean which is still working to resolve this issue as soon as possible. We apologize for the mistake and any inconvenience is highly regrated.
Posted Jun 14, 2022 - 03:12 UTC
This incident affected: Cloud Providers (DigitalOcean).