DNS Resolver Issue - Latency

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 21:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 10:23 UTC

Identified

We are experiencing intermittent failures and latency with DNS resolution in several regions. Users may encounter issues with name resolution during this period. We sincerely apologize for the inconvenience and are working with our upstream provider. We will provide a comprehensive update once a resolution is in place
Posted Sep 09, 2025 - 05:00 UTC
This incident affected: Cloud Providers (Vultr).