Temporary Service Disruption(Cloudways.com)
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted May 16, 2022 - 06:53 UTC
Investigating
We are currently facing service disruption on Cloudways.com and our team is investigation this issue right now. However, Platform.cloudways.com is completely accessible and working. This disruption does not impact any cloud services.
Posted May 16, 2022 - 06:40 UTC
This incident affected: Cloudways Home.