Cloudways Platform | UI Performance Delays

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 16:53 UTC

Monitoring

A fix has been deployed to address elevated latency in parts of the platform UI. Early metrics show improvement and error rates are stable. We’re closely monitoring page load and API latency to ensure full stability. If you still experience slowness, please relogin and try again.
Posted Oct 07, 2025 - 07:45 UTC

Investigating

We’re currently experiencing some performance delays on the platform’s user interface. Our team is actively investigating the cause and working diligently to restore optimal performance shortly. We appreciate your patience and understanding.
Posted Oct 07, 2025 - 01:39 UTC
This incident affected: Cloudways Cloud Platform Console.