Unable to Access Rackspace Webmail

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Jan 08, 2025 - 16:06 UTC

Investigating

We are currently experiencing technical issue on Rackspace's webmail login page. Please note that email delivery remains unaffected.

Our team is coordinating with the Rackspace team on this matter. We sincerely apologise for the inconvenience caused
Posted Jan 07, 2025 - 15:50 UTC
This incident affected: Add-on Services (Rackspace Email).