Rackspace Addon Experiencing Issues
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Apr 30, 2023 - 12:12 UTC
Investigating
We are currently experiencing a technical issue that is preventing the creation of new Rackspace mailboxes.

Our backend team is investigating the issue and coordinating with the Rackspace team, we will post an update on the issue as soon as we can. The inconvenience caused to our customers is highly regretted.
Posted Apr 29, 2023 - 02:29 UTC
This incident affected: Add-on Services (Rackspace Email).