Vultr Outrage in Multiple Regions
Incident Report for Cloudways
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 22:45 UTC
Investigating
We are currently facing outrage in multiple regions from Vultr and investigating this. We will keep posting details as soon as possible.
Posted Oct 06, 2021 - 19:33 UTC
This incident affected: Cloudways Cloud Platform Service.