Degraded Service Affecting Elastic Email Add-on

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 01:20 UTC

Monitoring

Service has been restored for the Elastic Email add-on, and delivery systems are returning to normal operations. We are actively monitoring performance to guarantee full stability. Thank you for your patience while we verify complete restoration.
Posted Sep 01, 2026 - 07:47 UTC

Investigating

We are aware of an ongoing upstream issue with Elastic Email that is temporarily impacting email delivery for affected Cloudways accounts.

Upstream engineers are actively investigating, and our team is closely following their progress. Further updates will be posted here shortly. Thank you for your patience while this is being resolved.
Posted Sep 01, 2026 - 07:42 UTC
This incident affected: Add-on Services (Elastic Email).